Windows Perl Scripting Forums » News

Unable to install DBD-Oracle

(1 post)
  • Started 11 years ago by srikantvm

Tags:


  1. srikantvm
    Member

    Hi All,

    I am using perl, v5.8.8 built for MSWin32-x86-multi-thread and i tried installing the DBD-Oracle module but unable to install. Please find below the steps followed by me:

    1) I first tried installing Oracle.pm using the Activestate PPM but, i got an connection error to the activestate perl module repository.

    2) Then i tried changing the http_proxy, it seemed to work fine. I was able to connect to the activestate perl module repository but while downloading the DBD-Oracle.pm it has given an error "404 not found".

    3) Then i tried installing the perl module following the classic unix steps i.e.,
      a) downloading from CPAN.org
      b) unzipping and decompressing the files into a folder.
      c) perl Makefile.PL
      d) make
      e) make install
    But the result for the above steps was some compiler issue with C. Please find below the error i got

    "*** You're using Microsoft Visual C++ compiler or similar but the LIB and INCLUDE environment variables are not both set. You need to run the VCVARS32.BAT batch file that was supplied with the compiler before you can use it. A copy of vcvars32.bat can typically be found in the following directories under your Visual Studio install directory: Visual C++ 6.0: vc98\bin Visual Studio .NET: vc7\bin Find it, run it, then retry this. If you think this error is not correct then just set the LIB and INCLUDE environment variables to some value to disable the check."

    4) Then i tried copying the DBD-Oracle.pm version 1.20 to "C:\Perl\lib\DBD\" and tried executing the my code that connects to the Oracle database and fetches some information. I got the following error:

    "install_driver(Oracle) failed: Can't locate loadable object for module DBD::Oracle in @INC (@INC contains: C:\Perl\lib C:/Perl/site/lib C:/Perl/lib .) at (eval 4) line 3 Compilation failed in require at (eval 4) line 3. Perhaps a module that DBD::Oracle requires hasn't been fully installed at DB_Connect.pl line 10". Please help me regarding the same.

    Thanks & Regards,
    Srikant

    Posted 11 years ago #

RSS feed for this topic

Reply

You must log in to post.